Удаление пробелов из чисел в 1С

Просмотров:
Удаление пробелов из чисел в 1С

Часто сталкиваясь с преобразованием числовых значений в строку, и для того, что бы все функции отрабатывали так, как нужно, мне практически каждый раз было необходимо убирать пробелы из чисел. Со временем я узнал несколько способов, как можно решить этот вопрос. И сегодня поделюсь ими с вами!

Для начала создадим простенькую форму.

 

И в модуле формы пишем следующее:

Процедура БезИзмененийНажатие(Элемент)
	//Здесь мы просто вставим в строку число без изменений
	Строка = ЧислоСПробелами;
КонецПроцедуры
 
Процедура УбратьСтрЗамНажатие(Элемент)
Строка = ЧислоСПробелами;
//1 вариант. Заменить неразрывный пробел. Это не простой пробел,
//а именно неразрывный пробел. Его можно скопировать прямо из числа.
Строка = СтрЗаменить(Строка," ","");
КонецПроцедуры
 
Процедура УбираемЧерезСтрЗам2Нажатие(Элемент)
Строка = ЧислоСПробелами;
//2 вариант. Так же, заменить неразрывный пробел.
//Но в этот раз мы укажем неразрывный пробел через "Символы"
Строка = СтрЗаменить(Строка,Символы.НПП,"");
КонецПроцедуры
 
Процедура УбираемЧерезФорматНажатие(Элемент)
Строка = ЧислоСПробелами;
//3 вариант. Изменение формата числа через "Формат".
//Преобразуем с помощью форматной строки "ЧГ=0"
Строка = Формат(ЧислоСПробелами,"ЧГ=0");
КонецПроцедуры;

В примере ниже Вы можете посмотреть, как отрабатывают процедуры на практике.

Скачать пример обработки по удалению пробелов из чисел 1С

Администратор

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *